Any thoughts on that? Comment 1. I did a test with a QuickTime file which has 5. Not all of them have 5. The bottom line is: no issues. The sound does work as expected. I even physically disconnected my front left and right channels so, that I can confirm the quality of the sound from other channels. Still, it works like a dream. Did you confirm your audio setup on Yamaha end?

Mac OS X Dolby Digital with Mac Mini [solved] - Hacker's ramblings

Thanks for this. Now, though, I'm not sure if the following happened because I unplugged the HDMI cord and changed it to a different port or if the receiver cycles the settings every time it is shut off. Anyways, the stutter returned and I had to repeat the steps here, but viola, all was well again. I'll report back if it was the HDMI port change or the receiver shutting off. Hopefully the former, so that I don't have to mess with these settings every time the receiver gets turned off and on.

Comments 4.

Get The Latest From Maciverse

What you're describing is pretty much how the HDMI-output works for me. It is quite unstable and behavior cannot be easily reproduced. Anyway, hopefully your sound works properly from now on. I tweeted to Yamaha Hub this page and suggesting that they need to roll out a firmware update to address the problem. Might be worth tossing out a tweet too. Don't know how seriously they look into stuff though.

Do you have an URL to the tweet? I'm not sure why it works, but it does. I have a mac mini , Yamaha receiver, samsung tv. In step one I assume this is in System Preferences? I have selected outputs as Samsung. In step 2, in audi midi setup it shows the source as Samsung. I only have drop down for 2 ch 24 bit, 20 bit or 16 bit. There is no drop down for 8 or 6 channels. And nothing about encoded digital output. Yes, the sound-settings are in System Preferences. You are 2nd person to comment, that the multi-channel selection is not available.

However, like I wrote in my post, I cannot even retrace my own steps. I cannot get the sound setup broken anymore, it is only in the working mode. It looks like the Mac has a life of its own and user's wishes have very little to do with that. Yes, I have a similar problem to other commenters here.


  1. best sudoku app for mac.
  2. After making the connection!
  3. No sound on Mac mini through HDMI.!

It's pretty crappy, to have to buy an external sound card with optical out to pass it to the amp. Can anyone else confirm my suspicion that this might be a driver problem, if so, how can it be fixed. I didn't found anything else related to this, but it's the most logical guess. You didn't mention anything about your amp. Does your amp have any HDMi-settings in it? Now I'm confused.


  1. audio - HDMI sound output mysteriously no longer works in Mac OS X (Yosemite) - Super User.
  2. pro tools 10 shortcuts pdf mac;
  3. task manager mac os 10.6.
  4. how to delete skype account on mac lion.
  5. wintv-hvr 900 software download for mac.

Your amp is connected via an optical cable to your TV? How does the picture go?

LMP Mini-DisplayPort to HDMI adapter, 4K

Via HDMi? Shouldn't you try simplifying your setup? I might've expressed myself bad. So, I have the following connections: 1. PS4 - optical - AMP 2. Thanks for the clarification.

How To Connect Mac To TV With Sound From TV

Now I understand your setup. In my opinion you're pushing the envelope here. Now that Mac is notoriously difficult to setup into multi-channel and given your complex cabling, unfortunately you're on your own there. This is the part where you break the envelope and wings start to tear off. What I'd recommend is to look for a new amp what would simplify your setup a lot. Hello I cant seem to locate the Audio Devices panel you're showing on this how-to the only panel I can locate that is the same is the Sound panel please help Comment 1.

Not "Audio Devices". Hi, Thanks for the good post to solve the problem. I just bought EOL mini couple of days ago and I was very disappointed when noticed that multichannel sound is not working. Setup is Denon X, mini, and Optoma projector. All connected with HDMI. Mini - Denon - Optoma. I have exact same issue you had the solving goes exact same way except my setup is not yet working correctly. I changed it back 8chbit integer and I am able to get the test sound from speaker configuration for each speaker correctly.

I finally downloaded VLC and 7. It works fine. All channels are working correctly. At least some hope for this setup to serve as media server. Hi, I have the exact same setup. The new mac mini connected to my YamahaRx-V receiver that is connected to my samsung tv. But when playing something that is 5. Any help? Comments 2. As I tried to say in my blog post, that I cannot make my Mac Mini 5. It seems to live a life of its own and nobody knows the rules. I see I'm so disappointed with this One last doubt.

What the mac mini shows for you now, connected to the TV Samsung or to the receiver? My Mac still insists, that it is connected to the TV. However, 5. You have to reset audio mini again when is on. If you close amplifier or reboot it goes back to 2 channel stereo, it does not keeps the setup. It is uncomfortable to set it again and again but it works, you can choose up to 8.

What I also did was change the Sony TV's audio settings to play through "audio system" rather than "tv speakers" and the final destination of the audio seemed to change and I got 8 channel afterwards. My TV is always on audio system.